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Simple harmonic motion  

Introduction 

When you suspend an object from a spring, the spring will stretch. If you gently pull on the object, which stretches 
the spring some more, then release it, the spring will provide a restoring force that will cause the object to oscillate 
in what is known as simple harmonic motion (SHM). In this experiment, you will examine this type of motion by 
studying the periodic motion experienced by a vertical mass attached to a spring. It can be described as a to-and-
fro or vibrating type of motion for objects stretched or bent from their normal positions and then released. Such 
an object moves back and forth along a fixed path, repeating over and over this fixed series of motions and 
returning to each position and velocity after a definite period of time. 
 
The conical harmonic motion spring used in this experiment is a truncated cone made of spring brass wire. Its 
elongations are closely proportional at applied forces. The windings of the truncated cone interfere less with each 
other than the windings of a helical spring which produces a truly sinusoidal motion.  
 
Imagine a mass that is in equilibrium at the end of a spring that is hanging vertically from a support. If the mass is 

pulled down a small distance and released, the spring exerts a restoring force, �⃗� = −𝑘�⃗�, where �⃗� is the distance 

the spring is displaced from equilibrium and 𝑘 is the spring constant of the spring. The negative sign indicates that 
the force is directed opposite to the direction of the displacement of the mass. 
 
As the mass rises, its speed increases as it moves toward its equilibrium point. It continues to move above the 
equilibrium point and stops at a height where its potential energy closely matches the kinetic energy it had as it 
passed the equilibrium point. From this point it moves downward again, gaining speed as it falls. When it moves 
below the equilibrium point, it begins to stretch the spring again, and the pattern of motion is repeated. 
 
For a mass on an ideal spring (spring has no mass), the position as a function of time is described by simple 
harmonic motion: 

𝑥(𝑡) = 𝐴 cos(𝜔𝑡 + 𝜃), 
 
where 𝐴 is the amplitude of the oscillations, 𝜔 is the angular frequency and 𝜃 is the phase constant. The angular 
frequency relates to the period of oscillation as 𝜔 = 2𝜋/𝑇. The period of oscillation, 𝑇, for an object in simple 
harmonic motion depends on the mass, 𝑚, and the spring constant, 𝑘: 
 

𝑇 = 2𝜋√
𝑚

𝑘
  . 

 
As the mass oscillates up and down, its energy changes between kinetic and potential. If friction and drag are 
ignored, the total energy of the system is constant. However, since the spring itself has mass, a correction must be 
applied to the equation for the period of oscillation. The corrected equation is:  
 

𝑇 = 2𝜋√
𝑚 + 𝛾𝑚𝑠

𝑘
  , 

 
where 𝑚𝑠 is the mass of the spring and 𝛾 is a constant between 0 and 1 which depends on the type of spring. The 
correction simply consists of using an effective mass that is the sum of the suspended mass and a fraction of the 
mass of the spring. For a regular uniform spring, the fraction 𝛾 is 1 3⁄ . In this experiment, you will not only have to 
experimentally determine the value of the spring constant of the conical harmonic motion spring but also its 𝛾 
value.    
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Suggested reading  

Students taking Suggested reading 

PHY 1121 Sections 14.1 to 14.3 Young, H. D., Freedman, R. A., University Physics with Modern 
Physics, 13th edition. Addison-Wesley (2012). 

PHY 1321-1331 Sections 15.1 to 15.3 Serway, R. A., Jewett, J. W., Physics for Scientists and Engineers 
with Modern Physics, eight edition. Brooks/Cole (2010). 

PHY 1124 Sections 15.1 to 15.4 Halliday, D., Resnick, R., Walker, J., Fundamentals of Physics, 9th 
edition. Wiley (2011). 

 

Objectives 

✓ Collect position vs. time data as a mass, hanging from a spring, is set in an oscillating motion.  
✓ Determine the best fit equation for the position vs. time graph of an object undergoing simple harmonic 

motion (SHM).  
✓ Relate the parameters in the best-fit equation for a position vs. time graph to their physical counterparts 

in the system.  
✓ Compare the force constant of a conical harmonic spring obtained from static measurements with that 

found by a dynamic method.  
✓ Estimate the correction factor, 𝛾, to calculate the effective mass of the system for the conical harmonic 

spring. 
  

Materials 

• Computer equipped with Logger Pro and a Vernier computer interface 

• Force sensor 

• Motion detector and motion detector guard  

• Table C-clamp with rod and clamp holders  

• Harmonic spring  

• Mass hanger and slotted masses set (5 x 100 g) 

• Electronic balance (one per classroom)  
 

Safety warnings 

Never hang masses above the motion detector without using the motion detector guard.  Dropping a mass on the 
detector could cause serious damage to the detector.  Please also be careful to not overstretch the spring as you 
only need to observe small amplitude oscillations (a few centimeters is enough). When suspending masses to the 
spring, you should always hold the masses until you find the equilibrium point and then slightly pull them to start 
the oscillations (do not let the masses fall from an arbitrary point).     
 

References for this manual  

• Gastineau, J., Appel, K., Bakken, C., Sorensen, R., Vernier, D., Physics with Vernier. Vernier software and 
Technology (2007).  

• Dukerich, L., Advanced Physics with Vernier – Mechanics. Vernier software and Technology (2011).  

• Physics with the Xplorer GLX. PASCO scientific (2006). 
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Procedure 

Preliminary manipulations 

Step 1. Turn on your computer and launch the Logger Pro program. You should see a value for force as well as 
position in the bottom left corner.  
 

Step 2. Prepare the setup presented in Figure 1. Place the motion detector on the floor beneath the mass 
hanger. Place the wire basket over the motion detector to protect it. The motion detector’s face should 
be directly under the hanging mass.  
 

Step 3. Add 300 g to the mass hanger to stretch the spring and let it settle.  Make sure the force sensor is set to 
10N and is vertically aligned.  If you rotate the force sensor, you should see the force reading in Logger 
Pro changing.  The vertical alignment of the sensor is reached when the force you read is maximized.   
 

Step 4. Click Experiment → Zero… to zero both sensors. Pull the hanger and mass slightly, then release. When 
the hanger is oscillating smoothly, begin collecting data. If the position-time graph does not appear to 
be a smooth curve, move the motion detector and repeat until you get a smooth curve. Once you are 
satisfied, make sure to not move the motion detector until the end of the experiment.     
 

Step 5. Perform a sinusoidal fit of your position vs. time graph. To do so, click Analyze → Curve Fit…. Select 
A*sin(B*t+C)+D from the general equation list. Click Try Fit, then OK.  
 

This fit returns four parameters: 
- A:  the amplitude of the oscillations (in m); 
- B:  the angular frequency, 𝜔, of the oscillations (in rad/s);  
- C: the phase constant synchronizing your sinusoidal function with your oscillations;  
- D: the offset parameter that is necessary when your equilibrium position is not the zero position 

of the motion detector. 
 

Step 6. Perform the same fit for the velocity vs. time, the acceleration vs. time and the force vs. time graphs.  
 

Step 7. Note the amplitude, the frequency and the phase parameters of your four fits in Table 1 and answer the 
questions in the lab report section.  

 
 

 

 
Figure 1 - Simple harmonic motion setup 
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Part 1 - Spring constant from static measurements 

Step 1. Remove the 300 g from your mass hanger in order to have a setup as in Figure 1a (empty mass hanger).  
  

Step 2. Click Experiment → Zero… to zero both sensors.  For now on, the position measured with the motion 
detector will correspond to the displacement, ∆𝑦, as in Figure 1 and the force reading will relate to the 
extra mass you will add to the mass hanger.    
 

Step 3. Add 100 g to your mass hanger and let it settle. Click Collect to collect data for 10 s. Select the position 
vs. time graph and click Analyze → Statistics. Record the mean value in the information box as your 
average displacement, ∆𝑦, during the 10 s of data collection. Weigh the mass you added to the hanger 
and start filling Table 2.  
 

Step 4. Repeat the last step increasing the suspended mass by 100 g and complete filling Table 2.  
 

Step 5. Using Logger Pro, plot a graph (Graph 1) of the extending force (𝑚𝑔, with 𝑔 = 9.81m/s2) against the 
extension (∆𝑦).   
 

Step 6. Perform a linear regression and find the force constant, 𝑘, of the spring.  Print your Graph 1 to a pdf file. 
Make sure you use the printer CutePDF to print the graph.  
 

Step 7. We strongly recommend that you save all the work you do during the lab in case you need to review it 
later. Click File → Save As… to save your experiment file (suggested name: 
k_static_YOUR_NAMES.cmbl). You can either send the file to yourself by email or save it on a USB key.  
 

Part 2 - Spring constant from dynamic measurements 

In the introduction, we learned that the period of oscillation is given by 𝑇 = 2𝜋√(𝑚 + 𝛾𝑚𝑠) 𝑘⁄ . If we square this 

formula, we get: 
 

𝑇2 =
4𝜋2𝑚

𝑘
+

4𝜋2𝛾𝑚𝑠

𝑘
 . 

 
In this part of the experiment, we will measure a series of oscillation periods squared, 𝑇2, as a function of the 
suspended masses, 𝑚. Using the equation above, you will be able to estimate the spring constant, 𝑘, from the 
slope of your graph and the correction factor, 𝛾, from your y-intercept.        
 

Step 1. Measure the weight of the mass hanger and the spring.   
 

Step 2. Hang the mass hanger plus 100 g on the spring and let it settle. Pull the hanger and the weight slightly, 
then release. When the hanger is oscillating smoothly, begin collecting data.  
 

Step 3. Perform a sinusoidal fit of your position vs. time graph.  
 

Step 4. Record the total suspended mass (hanger + 100 g) and the angular frequency from your fit in Table 3.   
 

Step 5. Repeat the last three steps with increasing mass to complete Table 3. Calculate the square periods 
starting from 𝑇 = 2𝜋 𝜔⁄ .  
 

Step 6. Prepare a graph (Graph 2) of the square period, 𝑇2, plotted against the total suspended mass, 𝑚.  
 

Step 7. Perform a linear regression. Find the force constant, 𝑘, of the spring from the slope of Graph 2 and the 
correction factor, 𝛾, from the 𝑦-intercept of Graph 2 (see pages 5 and 6 of the lab report). 
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Step 8. Print your Graph 2 to a pdf file (user the printer CutePDF). Save your experiment file (suggested name: 
k_dynamic_YOUR_NAMES.cmbl).   
 

 

Part 3 - Amplitude vs. frequency of oscillations 

Step 1. Using the mass hanger + 300 g, investigate the effect of the amplitude on the frequency of oscillations. 
Simply perform a series of fits with amplitudes (the parameter A of your fits) between ~0.01 m and 
~0.1m.  Do not overstretch the spring. Note the amplitudes and the corresponding frequencies (the B 
parameter of your fits). Record your results in Table 4. 

 

Cleaning up your station 

Step 1. Submit your graphs in Brightspace. If you locally saved your files, send them to yourself by email. Pick up 
your USB key if you used one to save your files.  Turn off the computer.  
 

Step 2. Put the masses, the mass hanger and the spring back on the table. Put the motion detector and the 
guard back on the table as well.    
 

Step 3. Recycle scrap paper and throw away any garbage. Leave your station as clean as you can.   
 

Step 4. Push back the monitor, keyboard and mouse. Also please push your chairs back under the table.  
 
 


